Ошибка после изменения домена

Автор Сообщение

pasha_link

Павел
#1/09.04.2015 22:58
0

Пользователи

Карма: +1

Добрый день.

После того, как сменил доменное имя на сайте все работает, кроме авторизации.

Выдает ошибку:

Ошибка в параметрах запроса

Один из параметров запроса недействителен или устарел. Вернитесь назад и попробуйте отправить форму заново.

Раньше сайт был на поддомене другого доменя. Возвращаю на него - все начинает работать.

Помогите пожалуйста...

 

 

Сообщения: 11

dimka0205

Дмитрий
#4/10.04.2015 08:26
0

Аватар

Пользователи

Карма: +12

Я кстати тоже сталкивался, оставлял здесь подобное решение проблемы какое назвал пользователь выше, в поиске найти не смог, кто и зачем удалил не понимаю

Добавлено 17 минут спустя:

Все нашёл свой пост, предлагаю админам создать тему с решениями проблем по работе с котонти, закрепить и разместить тему в топе, собирать все решения тех или иных проблем туда, я думаю чем шерстить по форуму поиском, легче будет зайти в тему и выбрать нужный раздел
Сообщения: 229

pasha_link

Павел
#5/10.04.2015 11:39
0

Пользователи

Карма: +1

Менял в config файле, менял в таблице flance_config два параметра cookiedomain и cookiepath, чистил flance_cache. Ничего не вышло.

Сообщения: 11

dimka0205

Дмитрий
#6/10.04.2015 12:22
+1

Аватар

Пользователи

Карма: +12

Кукидомайн и кукипатч надо очистить полностью

Добавлено 22 секунды спустя:

Имею ввиду в БД

Добавлено 1 минута спустя:

И кэш браузера по чистить
Сообщения: 229

pasha_link

Павел
#7/10.04.2015 12:37
0

Пользователи

Карма: +1

Только что почистил - ничего не изменилось

Сообщения: 11

pasha_link

Павел
#9/10.04.2015 14:35
0

Пользователи

Карма: +1

Кукидомайн и кукипатч почистил полностью в БД. Кэш браузера тоже очистил.

Адрес сайта: поручить.рф

Сообщения: 11

Cmsworks

Булат
#10/10.04.2015 14:51
0

Администраторы

Карма: +683

Домен в конфиге написан кириллицей или в формате xn--h1alcfle2a6b.xn--p1ai?

Сообщения: 2416

Опытный веб-разработчик, фрилансер.
Разрабатываю сайты любой сложности на профессиональных фреймворках.

------

Почта для связи: developer@cmsworks.ru

pasha_link

Павел
#11/10.04.2015 16:13
0

Пользователи

Карма: +1

 xn--h1alcfle2a6b.xn--p1ai

Сообщения: 11

Bond

Артур
#12/10.04.2015 17:01
0

Пользователи

Карма: +18

Интересно даже. Впервые встречаю такую проблему. Может с ЧПУ намудрили?

Сообщения: 62

pasha_link

Павел
#13/10.04.2015 17:11
+1

Пользователи

Карма: +1

Отключил сейчас расширение для ЧПУ (URL Editor) - ситуация не поменялась...

Добавлено 7 минут спустя:

В общем сейчас заметил такую штуку. Сайт до этого находился на поддомене другого РФ-домена. Примерно так st1.домен.рф

Меняя домен на xn--h1alcfle2a6b.​xn--p1ai - получается такая ерунда с авторизацией.

Однако...

Если создать поддомен st3.домен.рф и поставить его под сайт - то все работает и авторизуется.

Добавлено 4 минуты спустя:

Более того. Создал поддомен от нового адреса xn--h1alcfle2a6b.​xn--p1ai => st1.поручить.рф и все работает

 

Добавлено 8 минут спустя:

А на основном адресе не хочет... Голова уже болит

 

Добавлено 2 минуты спустя:

ЗАРАБОТАЛО. В конфиге $cfg['mainurl'] = 'http://www.xn--h1alcfle2a6b.xn--p1ai'; поставил www с точкой перед адресом сайта. Видимо не переваривает если сайт начинается не с латинской буквы.

Сообщения: 11